
  
    
 















<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://roanoke.com/content/tncms/live/" />
<meta name="keywords" content="bill, work, unions, christianity, thelma, brenda durham, betty hutchison roop, charles hutchison, billy a. roop, kristal fulcher" />
<meta name="news_keywords" content="bill, work, unions, christianity, thelma, brenda durham, betty hutchison roop, charles hutchison, billy a. roop, kristal fulcher" />
<meta name="description" content="ROOP, Billy A. April 20, 1949 - July 4, 2020 Billy A. Roop, of Christiansburg, passed away on Saturday, July 4, 2020, after a brief battle with liver cancer. He" />
<meta name="author" content="" />
<meta name="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1, user-scalable=0, shrink-to-fit=no" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="apple-itunes-app" content="app-id=com.omaha.id2922" />
<meta name="google-play-app" content="app-id=com.omaha.id2922" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://roanoke.com/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg?crop=229%2C129%2C10%2C0&amp;resize=356%2C200&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="356" />
<meta property="og:image:height" content="200" />
<meta property="og:title" content="ROOP,, Billy A." />
<meta property="og:description" content="ROOP, Billy A. April 20, 1949 - July 4, 2020 Billy A. Roop, of Christiansburg, passed away on Saturday, July 4, 2020, after a brief battle with liver cancer. He" />
<meta property="og:site_name" content="Roanoke Times" />
<meta property="og:section" content="Obituaries" />
<meta property="fb:app_id" content="251357365028982" />
<meta property="article:publisher" content="https://www.facebook.com/roanoketimes/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@roanoketimes" />
<meta name="twitter:image:alt" content="ROOP,, Billy A." />
<meta name="parsely-title" content="ROOP,, Billy A." />
<meta name="parsely-link" content="https://roanoke.com/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html" />
<meta name="parsely-type" content="post" />
<meta name="parsely-image-url" content="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg?crop=229%2C129%2C10%2C0&amp;resize=356%2C200&amp;order=crop%2Cresize" />
<meta name="parsely-pub-date" content="2020-07-07T00:00:00-04:00" />
<meta name="parsely-section" content="obituaries" />
<meta name="parsely-author" content="" />
<meta name="parsely-tags" content="" />
<meta name="parsely-post-id" content="dd51a29f-a21e-588d-8f30-bce5fc65e419" />
<link rel="manifest" href="/tncms/messaging/manifest/" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/font-awesome.min.e5604f5bf47d3b8b5552d999180549d2.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.0c3e31df0be5a1f4c4c0ce9102edb567.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.f5e0209e8fa74e9037c8703df61fdb9c.css"/>
<!--[if lt IE 9]><link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/ie.css"/><![endif]-->
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/live/libraries/flex/components/bh_flex/resources/styles/lee-ds.css?_dc=1593583277"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/live/libraries/flex/components/bh_flex/resources/styles/bhmedia-custom.css?_dc=1593583277"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=PT+Serif:400,600,700|Open+Sans:400,700,600,300,300italic,400italic,600italic"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-notification-controls.e115619c5ab5d4eb38fbd29cc0d2ea9b.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"asset":{"id":"dd51a29f-a21e-588d-8f30-bce5fc65e419","app":"editorial"},"page":{"app":"editorial","skin":"flex-editorial","theme":"flex","http_status":200},"client":{"is_bot":"no","noscript":false,"is_gdpr":"no"},"system":{"render_time":270}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="//tags.crwdcntrl.net/c/6892/cc.js?ns=_cc6892" id="LOTCC_6892"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc6892.add('tp', 'TNNW');
		_cc6892.add('act', ' User Login');
		_cc6892.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc6892.add('med', 'geo: new_river_valley');
	_cc6892.bcp();
</script>

<script src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/live/libraries/flex/components/bh_flex/resources/scripts/bhmedia-custom.js?_dc=1593583277"></script>
<script>/*<![CDATA[*/ var field59 = field59 || {}; field59.ipo = { "global": { "dfpConfig": { "prerollTemplate": "https://pubads.g.doubleclick.net/gampad/live/ads?iu=/167885573/roanoke_video&description_url=http%3A%2F%2Froanoke.com&env=vp&impl=s&correlator=&tfcd=0&npa=0&gdfp_req=1&output=vast&sz=640x360|640x480|400x300&cust_params=keyword%3D{keywords}%26category%3D{categories}&ciu_szs=300x250&unviewed_position_start=1" } } }; /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ac87000c8e1356e20584473075fd0f2e.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script>/*<![CDATA[*/ __tnt.adBlockEnabled = function() {
        if(__tnt.user.services || __tnt.urlHash('utm_medium') === 'email'){ 
            return false; 
        }
        return true;
    } /*]]>*/</script>
<script>/*<![CDATA[*/ (function(){
        if( __tnt.adBlockEnabled() ){
            var gcfs = document.createElement('script');
                gcfs.src = 'https://contributor.google.com/scripts/20d68aabf23de146/loader.js';
            var gcft = document.getElementsByTagName('script')[0];
                gcft.parentNode.insertBefore(gcfs, gcft);
        }
    })(); /*]]>*/</script>
<script>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</script>
<script>/*<![CDATA[*/ var __tnt = __tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.slots = __tnt.ads.dfp.slots || {};
    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["bill","work","unions","christianity","thelma","brenda durham","betty hutchison roop","charles hutchison","billy a. roop","kristal fulcher"];
    __tnt.ads.dfp.targeting.page=["asset","article","app-editorial"];
    if( typeof window.I10C != 'undefined' && typeof window.I10C.Morph != 'undefined' ){
        __tnt.ads.dfp.targeting.page.push('recover');
    }
    
    __tnt.docWidth = window.innerWidth;
    if( __tnt.docWidth > 1899 ){ 
        __tnt.docWidthBreakPoint = 'xl_screen';
    } else if ( __tnt.docWidth > 1619 ){
        __tnt.docWidthBreakPoint = 'lg_screen';
    } else if ( __tnt.docWidth > 991 ){
        __tnt.docWidthBreakPoint = 'md_screen';
    } else if ( __tnt.docWidth > 767 ){
        __tnt.docWidthBreakPoint = 'sm_screen';
    } else {
        __tnt.docWidthBreakPoint = 'xs_screen';
    }
    __tnt.ads.dfp.targeting.page.push(__tnt.docWidthBreakPoint);

    window.googletag = window.googletag || {};
    window.googletag.cmd = window.googletag.cmd || [];

    (function() {
        var gads = document.createElement('script');
        gads.async = true;
        gads.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
    })(); /*]]>*/</script>
<script>/*<![CDATA[*/ window.APS_dfp_ads = [];
    
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
    
    apstag.init({
        pubID: '3536',
        adServer: 'googletag'
    }); /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.notify.6e1ca8839e8a715fdecb1c734223823a.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.notify.panel.1c7debce90f6bd1a3d679d0176d3712a.js"></script>
<script src="https://www.gstatic.com/firebasejs/6.6.2/firebase-app.js" defer="defer"></script>
<script src="https://www.gstatic.com/firebasejs/6.6.2/firebase-messaging.js" defer="defer"></script>
<script src="/shared-content/art/tncms/api/messaging.js" defer="defer"></script>
<script>/*<![CDATA[*/ document.addEventListener('DOMContentLoaded', function() {TNCMS.Messaging.init({messagingSenderId: '119986500483'});TNCMS.Messaging.onMessage(messagingCallback);}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>ROOP,, Billy A. | Obituaries | roanoke.com</title>
            
    
    <style>body { background-color: #fff; color: #444; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #4175aa; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #000; } .fixed-nav #main-navigation { background-color: #000 !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer-container, #site-footer { background-color: #fff; color: #000; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #ffffff; } .navbar-toggle .icon-bar { background-color: #ffffff !important; } .navbar-toggle .sr-only-show { color: #ffffff !important; } #site-top-nav .list-inline>li>a { color: #333; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header-container { background-color: #000; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #ffffff; } }#site-copyright a, #site-footer a { color: #000; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #106892; }#site-header-container{ border-bottom: 3px solid #106892; }#site-footer-container{ border-top: 3px solid #106892; } .tnt-bg-accent { background-color: #106892; } a .tnt-caret-down { color: #106892; } .block-title .block-title-inner { border-color: #106892; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #106892; } .form-control:focus { border-bottom-color: #106892; }</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://roanoke.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/0c35bf98-f2f9-11e6-bf01-572d76024d78.png" />
    
        <link rel="amphtml" href="https://roanoke.com/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.amp.html" /><link rel="alternate" type="application/rss+xml" title="ROOP,, Billy A. | Obituaries | roanoke.com" href="http://roanoke.com/search/?f=rss&amp;t=article&amp;c=obituaries&amp;l=50&amp;s=start_time&amp;sd=desc" />
    
    <link rel="canonical" href="https://roanoke.com/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html" />
    
            
    <script defer src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a8c7e0dc594b3a0b53141cdea833eee5.js"></script>
            
<script>
var user_input = [];
user_input.push({Email:null});
var validation = [];

$(document).ready( function () {
    GetURLQueryStringValues();

    $("div.newsletter-container > div.footer > p").click(function() {
        launchSubscriptionModal($(this));
    });

	$("div[data-preview] span.preview").click(function() {
		overlayPreview($(this));
	});
});

function launchSubscriptionModal(e) {
    var modal = $('<div>').attr('class','subscribe-modal');
    var cont = $('<div>').attr('class','form');
    var email = $('<input>').attr('type','email').attr('name','email').attr('id','email').attr('placeholder','E-mail Address');
    var subBtn = $('<p>').attr('class','subscription-button').text('Subscribe');
    var closeBtn = $('<span>').attr('class','close-button').html('&times;');
    var newsletterID = e.parent().parent().data('newsletterid');
    var source = e.parent().parent().data('source');
        
    if ((user_input.length > 0) && (user_input[0].Email != null)) {
        // We are bypassing the modal window and using the data in user_input to subscribe.
        if ($(e).hasClass('subscribed')) {
            SubmitSubscription('unsub',e,user_input[0].Email,newsletterID,source);
        }  else {
            SubmitSubscription('sub',e,user_input[0].Email,newsletterID,source);
        }
    } else {
        $(modal).append($(cont).append($(email)).append($(subBtn))).append($(closeBtn));
        e.parent().parent().append($(modal).fadeIn(500));
        $(closeBtn).click(function() {
            $(modal).fadeOut(500, function() {$(modal).remove();});
        });
        $(email).blur(function() {user_input[0].Email = $(this).val();});
    }

    $(subBtn).click(function() {
        $(email).removeClass('error');
        validation.length = 0;
        if (email.val().trim() == '') {
        	validation.push( { error: "Email address is required.", element: $(email) } );
        }
        if (validation.length > 0) {
        	displayErrors();
        } else {
            if ($(e).hasClass('subscribed')) {
                SubmitSubscription('unsub',e,user_input[0].Email,newsletterID,source);
            } else {
                SubmitSubscription('sub',e,$(email).val(),newsletterID,source);
            }
        }
    });
}
//end launchSubscriptionModal()

function SubmitSubscription(cmd,c,e,l,s) {
    $.ajax({
        type: "GET",
        url: "https://www.roanoke.com/app/whatcounts/subscribe.php?command="+cmd+"&email=" + e + "&lists=" + l + "&source=" + JSON.stringify(s) + "&random=" + rNum(),
        contentType: "",
        dataType: "text",
        success: function(msg) {
            if (msg.indexOf('SUCCESS') > -1) {
                $("div.subscribe-modal").remove();
                if (cmd == 'sub') {
                    $(c).text('You have been subscribed.').attr('class','subscribed');
                } else {
                    $(c).text('Subscribe').removeClass('subscribed');
                }
            } else {
                $("div.subscribe-modal").remove();
                var valModal = $('<div>').attr('class','validation-modal');
                var btnOK = $('<button>').attr('class','ok').text('OK');
                var msg = $('<p>').text('There was an error. Please contact our webmaster.');
                $(valModal).append($(msg)).append($(btnOK));
                c.parent().parent().append($(valModal));
                $(btnOK).click(function() {$(valModal).remove();});
            }
        }
    });
}
//end SubmitSubscription()

function rNum() {return Math.floor((Math.random() * 100000000000) + 1);}
    
function displayErrors() {
    for (i=0; i<validation.length; i++) {
        var err = validation[i].error;
        var ele = validation[i].element;
        ele.attr('placeholder',err).addClass('error');
    }
}
//end displayErrors()

function overlayPreview(a) {
    a = a.parent().parent().data('preview');
    window.open(a);
}
//end overlayPreview()

function GetURLQueryStringValues() {
    var qsv = window.location.href.slice(window.location.href.indexOf('?') + 1).split('&');
    for (var i = 0; i < qsv.length; i++) {
        var q = qsv[i].split('=');
        if (q[0] == 'custom_source') {$("div.newsletter-container").attr('data-source','custom-' + q[1]);}
    }
}
</script><!-- Begin Lotame code --> 
<script type="text/javascript" src="//ad.crwdcntrl.net/5/c=6878/pe=y/var=ccauds"></script>
<script type="text/javascript">
var ccKeywords = "keyword=";
if (typeof(ccauds) != "undefined")
{
    for (var cci = 0; cci < ccauds.Profile.Audiences.Audience.length; cci++)
    {
        if (cci > 0)
        {
            ccKeywords += "&keyword=";
        }
        ccKeywords += ccauds.Profile.Audiences.Audience[cci].abbr;
    }
 }
 </script>
 <!-- End Lotame code -->
    <!-- Per BMT-6423 by RMD -->
    
    
    <script language="javascript" type="text/javascript">
        $(document).ready(function() {        
            //$('.new-search #site-search-1354626-btn ').html('<i class="fa fa-search" aria-hidden="true"></i>');    
        }); 
    </script>
    
    

    
          
    
  

        </head>
        <body class="fixed-scroll-nav app-editorial grid-mobile-pattern blox-asset uuid-dd51a29f-a21e-588d-8f30-bce5fc65e419 section-obituaries type-article infinity-disabled" data-path="/obituaries">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('roanoke.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.asset.id=dd51a29f-a21e-588d-8f30-bce5fc65e419&tncms.asset.app=editorial&tncms.page.app=editorial&tncms.page.skin=flex-editorial&tncms.page.theme=flex&tncms.page.http_status=200&tncms.client.is_bot=no&tncms.client.noscript=yes&tncms.client.is_gdpr=no&tncms.system.render_time=270" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push({"ga_ua":"UA-54716522-2","ga_ua_local":"UA-34219538-1","taxonomy_1":"obituaries","taxonomy_2":null,"taxonomy_3":null,"taxonomy_4":null,"taxonomy_5":null,"blox_platform":"desktop","blox_page_type":"asset","blox_domain":"roanoke.com","blox_skin":"flex-editorial","blox_application":"editorial","groups":{"content":"1","advertising":"2","utility":"3"},"content_group":"2","content_group_id":"obituaries","blox_sections":"obituaries","weather_temp":75,"weather_conditions":"Clear","asset_source":"local","blox_asset_type":"article","asset_section":null,"asset_id":"dd51a29f-a21e-588d-8f30-bce5fc65e419","asset_headline":"ROOP,, Billy A.","asset_byline":"","asset_pub_date":"07\/07\/2020","asset_pub_time":"12:00 am","asset_canonical":"https:\/\/roanoke.com\/obituaries\/roop-billy-a\/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html","asset_content_length":1740,"asset_related_length":0,"asset_tag_1":"bill","asset_tag_2":"work","asset_tag_3":"unions","asset_tag_4":"christianity","asset_tag_5":"thelma","asset_tag_6":"brenda durham","asset_tag_7":"betty hutchison roop","asset_tag_8":"charles hutchison","asset_tag_9":"billy a. roop","asset_tag_10":"kristal fulcher"});
                
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TDWDC2" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','GTM-TDWDC2');
        </script>

        <script>
            __tnt.googleEvent = function(obj) {
                dataLayer.push({
                    'event': 'gaTriggerEvent',
                    'gaEventCategory': obj.category,
                    'gaEventAction': obj.action,
                    'gaEventLabel': obj.label,
                    'gaEventValue': obj.value
                });
            }
            __tnt.googleSocial = function(obj) {
                dataLayer.push({
                    'event': 'socialEvent',
                    'socialNetwork': obj.network,
                    'socialAction': obj.socialAction,
                    'socialTarget': obj.url
                });
            }
            __tnt.googlePageView = function(obj) {
                var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                dataLayer.push({
                    'event': 'VirtualPageview',
                    'virtualPageURL': sURL,
                    'virtualPageTitle': obj.title
                });
            }
        </script>
        <!-- End Google Tag Manager -->
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        <div class="tnt-ads-container text-center "><div style="min-height:1px; min-width:2px;" class="tnt-ads dfp-ad" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="fixed-impact-top, atf" id="fixed-impact-top" data-dfp-size="[2,1]"></div></div>
    <div class="tnt-ads-container text-center "><div style="min-height:1px; min-width:1px;" class="tnt-ads dfp-ad" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="fixed-impact-bottom, btf" id="fixed-impact-bottom" data-dfp-size="[1,1]"></div></div>
    
        <div id="site-container">

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-753223" class="tncms-block site-brand-mark"><section id="block-753223" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/2b33d314-46b5-11e9-9b97-530cbed200f6.jpg" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div><div id="tncms-block-753281" class="tncms-block site-follow-us"><div class="follow-links-753281 default">
    
    <section id="block-753281" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/roanoketimes/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.twitter.com/roanoketimes" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
            <li>
                <a href="https://www.instagram.com/roanoketimes/" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
            <li>
                <a href="/emails/" title="Email" target="_blank" rel="noopener" class="btn btn-xs btn-link em">
                    <i class="fas tnt-envelope"></i>
                    <span class="sr-only">Email</span>
                </a>
            </li>
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://roanoke.com",
  "sameAs" : ["https://www.facebook.com/roanoketimes/","https://www.twitter.com/roanoketimes","https://www.instagram.com/roanoketimes/","/emails/"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-880956" class="tncms-block">
    <div style="padding-top: 10px; width: 80%; margin: auto;">
        <a class='btn btn-success btn-block bh-btn-limit' href="https://checkout.roanoke.com?g2i_source=voluntary&g2i_medium=onsite&g2i_campaign=subs2020&g2i_or_o=M2">Subscribe</a>
    </div>
</div><div id="tncms-block-749972" class="tncms-block"><div id="user-controls-749972" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://myaccount.Roanoke.com/Access?EntitlementCode=eEdition&flow=Access&mode=add&FromURL=https%3A%2F%2Froanoke.com%2Ftncms%2Fsubscription%2Factivate%3Freferer_url%3Dhttps%253A%252F%252Froanoke.com%252Fobituaries%252Froop-billy-a%252Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://roanoke.com/users/login/?referer_url=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://roanoke.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-749972').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" ><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://roanoke.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://roanoke.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://roanoke.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-749972').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://roanoke.com/users/logout/" id="user-logout-form-749972"><input type="hidden" name="referer_url" value="https://roanoke.com/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-1" data-target="#mobile-nav-left_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/news/local/"  class="nav-link tnt-section-local">Local</a>
                                </li><li>
                                    <a href="/news/crime"  class="nav-link tnt-section-crime-courts">Crime & Courts</a>
                                </li><li>
                                    <a href="/news/virginia/"  class="nav-link tnt-section-virginia">Virginia</a>
                                </li><li>
                                    <a href="/news/nrv/"  class="nav-link tnt-section-new-river-valley">New River Valley</a>
                                </li><li>
                                    <a href="/news/politics"  class="nav-link tnt-section-government-politics">Government & Politics</a>
                                </li><li>
                                    <a href="/business/"  class="nav-link tnt-section-business">Business</a>
                                </li><li>
                                    <a href="/news/education/"  class="nav-link tnt-section-education">Education</a>
                                </li><li>
                                    <a href="/news/national/"  class="nav-link tnt-section-national">National</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/obituaries/"  class="nav-link tnt-section-recent-obituaries">Recent Obituaries</a>
                                </li><li>
                                    <a href="/obituaries/search/?c=obituaries*&amp;t=article,collection"  class="nav-link tnt-section-find-an-obituary">Find an Obituary</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/site/forms/online_services/letter/"  class="nav-link tnt-section-submit-a-letter">Submit a Letter</a>
                                </li><li>
                                    <a href="/opinion/letters/"  class="nav-link tnt-section-letters">Letters</a>
                                </li><li>
                                    <a href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a href="/opinion/commentary/"  class="nav-link tnt-section-commentary">Commentary</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/college/va_tech/"  class="nav-link tnt-section-virginia-tech">Virginia Tech</a>
                                </li><li>
                                    <a href="/sports/college/uva/"  class="nav-link tnt-section-uva">UVa</a>
                                </li><li>
                                    <a href="/sports/high_schools/"  class="nav-link tnt-section-high-schools">High Schools</a>
                                </li><li>
                                    <a href="/sports/college/"  class="nav-link tnt-section-colleges">Colleges</a>
                                </li><li>
                                    <a href="/sports/local_pro_sports/"  class="nav-link tnt-section-local-pro-sports">Local Pro Sports</a>
                                </li><li>
                                    <a href="/sports/national/"  class="nav-link tnt-section-national">National</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/entertainment/"  class="nav-link tnt-section-entertainment">Entertainment</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/calendar/"  class="nav-link tnt-section-calendar">Calendar</a>
                                </li><li>
                                    <a href="/entertainment/arts/"  class="nav-link tnt-section-arts">Arts</a>
                                </li><li>
                                    <a href="/entertainment/puzzles"  class="nav-link tnt-section-comics-puzzles">Comics & Puzzles</a>
                                </li><li>
                                    <a href="/entertainment/music/"  class="nav-link tnt-section-music">Music</a>
                                </li><li>
                                    <a href="/lifestyles/"  class="nav-link tnt-section-lifestyles">Lifestyles</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/weather/"  class="nav-link tnt-section-weather">Weather</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/sponsored_content/"  class="nav-link tnt-section-sponsored-features">Sponsored Features</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/sponsored_content/community-experts/"  class="nav-link tnt-section-community-experts">Community Experts</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-nav-mobile-nav-left-below" class="tncms-region-nav"><div id="mobile-nav-left-below_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left-below_menu-child-1" data-target="#mobile-nav-left-below_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-print-edition">Print Edition</a>
                        </div>
                    </div><ul id="mobile-nav-left-below_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/etimes/"  class="nav-link tnt-section-etimes">eTimes</a>
                                </li><li>
                                    <a href="/classifieds/print_ads?l=10"  class="nav-link tnt-section-weekly-ads">Weekly Ads</a>
                                </li><li>
                                    <a href="/publications/"  class="nav-link tnt-section-special-sections">Special Sections</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left-below_menu-child-2" data-target="#mobile-nav-left-below_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/classifieds/"  class="nav-link tnt-section-buy-sell">Buy & Sell</a>
                        </div>
                    </div><ul id="mobile-nav-left-below_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="https://ads.roanoke.com/roanoke-adportal/classified/index.html"  target="_blank" rel="noopener" class="nav-link tnt-section-place-an-ad">Place an Ad</a>
                                </li><li>
                                    <a href="/real_estate/"  class="nav-link tnt-section-homes">Homes</a>
                                </li><li>
                                    <a href="/vehicles/"  class="nav-link tnt-section-cars">Cars</a>
                                </li><li>
                                    <a href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                                </li><li>
                                    <a href="/findit/"  class="nav-link tnt-section-business-directory">Business Directory</a>
                                </li><li>
                                    <a href="https://roanoke.scoreyourdeal.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-todays-deal">Today's Deal</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="http://roanoke.com/jobs/"  target="_blank" rel="noopener" class="nav-link tnt-section-jobs">Jobs</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left-below_menu-child-4" data-target="#mobile-nav-left-below_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-customer-service">Customer Service</a>
                        </div>
                    </div><ul id="mobile-nav-left-below_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="https://checkout.roanoke.com"  target="_blank" rel="noopener" class="nav-link tnt-section-subscribe">Subscribe</a>
                                </li><li>
                                    <a href="https://myaccount.roanoke.com/Dashboard"  target="_blank" rel="noopener" class="nav-link tnt-section-manage-subscription">Manage Subscription</a>
                                </li><li>
                                    <a href="https://myaccount.roanoke.com/Vacation"  target="_blank" rel="noopener" class="nav-link tnt-section-vacation-stopstart">Vacation Stop/Start</a>
                                </li><li>
                                    <a href="https://myaccount.roanoke.com/EZPay"  target="_blank" rel="noopener" class="nav-link tnt-section-pay-bill">Pay Bill</a>
                                </li><li>
                                    <a href="https://myaccount.roanoke.com/home"  target="_blank" rel="noopener" class="nav-link tnt-section-change-address">Change Address</a>
                                </li><li>
                                    <a href="https://myaccount.roanoke.com/Complaint"  target="_blank" rel="noopener" class="nav-link tnt-section-report-delivery-issue">Report Delivery Issue</a>
                                </li><li>
                                    <a href="/emails/"  class="nav-link tnt-section-newsletter-signup">Newsletter Signup</a>
                                </li><li>
                                    <a href="/photosubmissions/"  class="nav-link tnt-section-photo-submissions">Photo Submissions</a>
                                </li><li>
                                    <a href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/classifieds/community/announcements/legal"  class="nav-link tnt-section-public-notices">Public Notices</a>
                        </div>
                    </div></div></div></div>
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "><div id="tncms-block-753217" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-753217"><div class="col-xs-12"><small>&copy; 2020 Lee BHM Corp.</small></div>
    </section>
</div></div><div id="tncms-block-753482" class="tncms-block"><style type="text/css">
    .terms_privacy {margin-left: 15px; display: table; width: auto;}
    .terms_privacy small, .terms_privacy a {color: white;}
</style><div class="terms_privacy">
    <small>
            <a href="/site/terms.html">Terms of Use</a>
    </small>
    <small>
            |
            <a href="/site/terms.html#privacy">Privacy Policy</a>
    </small>
</div></div></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    

    

    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    

    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container">
                
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop fluid-header navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button>
                    
                    

                    
                        <div class="navbar-brand pos_left_menu_right_search">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-756878" class="tncms-block"><div id="site-logo-756878" class="site-logo-container text-left" >
        <div class="logo-top"></div>
        <div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/78aac6da-46b4-11e9-b5be-cf1e0cd351f1.png?resize=200%2C22" 
            srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/78aac6da-46b4-11e9-b5be-cf1e0cd351f1.png?resize=200%2C22 200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/78aac6da-46b4-11e9-b5be-cf1e0cd351f1.png?resize=300%2C33 300w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/78aac6da-46b4-11e9-b5be-cf1e0cd351f1.png?resize=400%2C44 400w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/78aac6da-46b4-11e9-b5be-cf1e0cd351f1.png?resize=540%2C59 540w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/78aac6da-46b4-11e9-b5be-cf1e0cd351f1.png?resize=750%2C82 750w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/78aac6da-46b4-11e9-b5be-cf1e0cd351f1.png?resize=1200%2C131 1200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/78aac6da-46b4-11e9-b5be-cf1e0cd351f1.png?resize=1700%2C185 1700w"
            sizes="100vw"
            class=" img-responsive lazyload tnt-prop-img"
            alt="site-logo"></a>
        </div>
        <div class="logo-bottom"></div>
    </div></div></div>
                            
                        </div>
                    

                    
                        <ul class="hidden-md hidden-lg nav navbar-nav pull-right site-search-full-mobile">
                            <li class="search-form-dropdown dropdown yamm-fw">
                                <a class="dropdown-toggle" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
                                <ul class="dropdown-menu">
                                    <li>
                                        <form action="/search/" method="GET" class="yamm-content">
                                            <input type="hidden" name="l" value="25">
                                            <input type="hidden" name="sd" value="desc">
                                            <input type="hidden" name="s" value="start_time">
                                            <input type="hidden" name="f" value="html">
                                            <input type="hidden" name="t" value="article,video,youtube,collection">
                                            <div class="input-group">
                                                <input name="q" type="text" placeholder="Search..." title="Site Search" class="form-control" autocomplete="off">
                                                <input type="submit" class="hide" value="Search">
                                                <span class="input-group-btn">
                                                    <button class="btn btn-default site-search-btn" type="submit">
                                                        Search
                                                    </button>
                                                </span>
                                            </div>
                                            <div class="clearfix"></div>
                                        </form>
                                    </li>
                                </ul>
                            </li>
                        </ul>
                        <script>
                            $('.site-search-full-mobile button[type="submit"]').on(__tnt.client.clickEvent, function(){
                                $('.site-search-full-mobile form').submit();
                                return false;
                            });
                        </script>
                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-773726" class="tncms-block"><style>
    #bh-flyover-button-btn-773726 .popover {
        width: auto;
        min-width: 300px;
        max-width: 500px;
        z-index: 1000;
    }

    #bh-flyover-button-btn-773726 div.popover-content h3 {
        color: #000;
        font-weight: normal;
        font-size: 20px;
        margin-top: 10px;
        margin-bottom: 15px;
    }
</style>
<a href='https://checkout.roanoke.com?g2i_source=voluntary&g2i_medium=onsite&g2i_campaign=subs2020&g2i_or_o=M2' id="bh-flyover-button-btn-773726" class="navbar-btn btn-subscribe">Subscribe</a><script>
    jQuery(document).ready(function($) {
        if (__tnt.user.services) {
            $('#bh-flyover-button-btn-773726').attr('href', 'https://checkout.roanoke.com?g2i_source=voluntary&g2i_medium=onsite&g2i_campaign=subs2020&g2i_or_o=M2').html('Subscribe');
        } else {
           var bSubOfferLoaded = Cookies.get('bh-flyover-ck');
           if ( !bSubOfferLoaded ) {
               var sButtonText = 'SALE! Only $1/month';
               var sButtonHref = 'https://checkout.roanoke.com?g2i_source=bannerbutton&g2i_medium=onsite&g2i_campaign=subs2020&g2i_or_o=M2';
               var sMemberBtnHtml = '<div class="text-center"><h3>Support our newsroom by joining at our lowest rate!</h3>'+
                                '<div class="padding-bottom"><a class="btn btn-danger" href="'+sButtonHref+'"><strong>'+sButtonText+'</strong></a>'+
                                '</div>';
               $('#bh-flyover-button-btn-773726').popover({
                    container: '#bh-flyover-button-btn-773726',
                    placement: 'bottom',
                    content: sMemberBtnHtml,
                    trigger: 'focus',
                    html: true,
                    delay: { 'show': 500 }
                });
    
                $('#bh-flyover-button-btn-773726').popover('show');
                Cookies.set('bh-flyover-ck', 'true', { path: '/', expires: 1 });
     
                $('#main-page-container').click(function(){
                    $('#bh-flyover-button-btn-773726').popover('hide');
                });
           }
        }
        $('#bh-flyover-button-nav-773726').show();
    });
</script></div><div id="tncms-block-749959" class="tncms-block new-search"><ul id="site-search-749959-dropdown" class="hidden-print nav navbar-nav navbar-right site-search-full">
        <li class="search-form-dropdown dropdown yamm-fw">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle"  data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-749959" action="/search/" method="GET" class="yamm-content">
    <input type="hidden" name="l" value="25">
    
        <input type="hidden" name="s" value="start_time">
        <input type="hidden" name="sd" value="desc">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default input-group-sm ">
        <input id="site-search-749959-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-749959-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-749959-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-749959').submit();
        return false;
    });

    $('#site-search-749959').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-749959 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-749959 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-749959-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-753219" class="tncms-block"><div id="user-controls-753219" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="nav navbar-nav navbar-right"><li><a  onclick="javascript:void(0); return false;"  data-toggle="dropdown"  class="user-control-link" rel="nofollow">
                        <span class="fas tnt-user"></span>
                    </a>
                    <ul class="dropdown-menu dropdown-menu-right" role="menu">
                        <li>
                            <div style="width: 300px; padding: 15px">
                                <div class="row padding-bottom">
                                    <div class="col-md-12">
                                        <h4>Log In Using Your Account</h4>
                                        <a role="menuitem" class="btn btn-block btn-primary" href="https://roanoke.com/users/login/?referer_url=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html" rel="nofollow">Log In</a>
                                    </div>
                                </div>
                                <div class="row">
                                    <div class="col-md-12">
                                        <div class="dropdown-signup"><strong>Don't have an account?</strong> <a role="menuitem" href="https://myaccount.Roanoke.com/Access?EntitlementCode=eEdition&flow=Access&mode=add&FromURL=https%3A%2F%2Froanoke.com%2Ftncms%2Fsubscription%2Factivate%3Freferer_url%3Dhttps%253A%252F%252Froanoke.com%252Fobituaries%252Froop-billy-a%252Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html" rel="nofollow">Sign Up Today</a></div>
                                    </div>
                                </div>
                            </div>
                        </li>
                    </ul>
                </li>
        </ul>
    </div>

    <div class="logged-in">
        
        
        <ul class="nav navbar-nav navbar-right">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" ><div class="tn-user-avatar pull-left"><!-- user avatar --></div><b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://roanoke.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://roanoke.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://roanoke.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-753219').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://roanoke.com/users/logout/" id="user-logout-form-753219"><input type="hidden" name="referer_url" value="https://roanoke.com/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-808846" class="tncms-block"><div id="notification-button-808846" class="notification-button pull-right" data-control="notification" data-id="808846" style="display:none;">
            <ul class="nav navbar-nav navbar-right">
                <li>
                    <a>
                        <span class="badge-dot tnt-bg-accent" style="display:none;"></span>
                        <i class="fas tnt-bell"></i>
                    </a>
                </li>
            </ul>
        </div></div><div id="tncms-block-749956" class="tncms-block"><div id="weather-749956" class="weather-current size-small pull-left">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=24010" class="dropdown-toggle" data-toggle="dropdown" >
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc small">
                    <span class="temp">75&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="24010"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-749956 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Roanoke, VA
                                
                                 <small>(24010)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Partly to mostly cloudy. A stray shower or thunderstorm is possible. High 89F. Winds SSE at 5 to 10 mph..</p>
                            <h5>Tonight</h5>
                            <p>Mostly cloudy in the evening with scattered thunderstorms developing after midnight. Low near 70F. Winds ESE at 5 to 10 mph. Chance of rain 40%.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: July 7, 2020 @ 12:46 am</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=24010"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link  tnt-section-news"  href="/news/local/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-etimes"  href="/etimes" >
                    <span class="nav-label">eTimes</span>
                </a></li><li>
                <a class="nav-link  tnt-section-buy-sell"  href="/classifieds/" >
                    <span class="nav-label">Buy & Sell</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
        <div class="visible-xs pull-right article-share-nav" style="background-color: #000">
            <span>Share This <i class="fas tnt-arrow-right"></i></span>
            <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=ROOP%2C%2C%20Billy%20A.&via=roanoketimes&url=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://roanoke.com/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20roanoke.com/tncms/asset/editorial/dd51a29f-a21e-588d-8f30-bce5fc65e419" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Broanoke.com%5D%20ROOP%2C%2C%20Billy%20A.&body=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul>
        </div>
            
        </div>
        
            
                
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-753253" class="tncms-block"></div><div id="tncms-block-753519" class="tncms-block"></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
        <div class="container-breakout">
        <div class="visible-lg visible-md" data-slug="" >
<div class="tnt-ads-container text-center hidden-xs"><div style="min-height:90px; min-width:728px;" class="tnt-ads dfp-ad dfp-ad-lite" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="fixed-leaderboard-top, atf, Top, Position2, 50" id="fixed-leaderboard-top" data-dfp-size="[[728,90], [970,90], [970,250]]" data-subscriber="true"></div></div>
    </div><div class="visible-sm"><div class="tnt-ads-container text-center hidden-xs"><div style="min-height:90px; min-width:728px;" class="tnt-ads dfp-ad dfp-ad-lite" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="fixed-leaderboard-top, atf, Top, Position2, 50" id="fixed-leaderboard-top-tablet" data-dfp-size="[728,90]" data-subscriber="true"></div></div>
    </div><div class="tnt-ads-container text-center hidden-sm hidden-md hidden-lg"><div style="min-height:50px; min-width:300px;" class="tnt-ads dfp-ad dfp-ad-lite" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="fixed-leaderboard-top, atf, Top, Position2, 50" id="fixed-leaderboard-top-mobile" data-dfp-size="[[300,50], [320,50]]" data-subscriber="true"></div></div>
    
       </div>
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-895299" class="tncms-block"><section id="block-895299" class="block emphasis-h3   " ><div class="block"><a href="https://ads.roanoke.com/roanoke-adportal/obits/index.html" rel="nofollow noopener" target="_blank">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/91a44cbe-753a-11ea-a109-2709a5557330.jpg?resize=200%2C10 200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/91a44cbe-753a-11ea-a109-2709a5557330.jpg?resize=300%2C14 300w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/91a44cbe-753a-11ea-a109-2709a5557330.jpg?resize=400%2C19 400w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/91a44cbe-753a-11ea-a109-2709a5557330.jpg?resize=540%2C26 540w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/91a44cbe-753a-11ea-a109-2709a5557330.jpg?resize=750%2C36 750w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/91a44cbe-753a-11ea-a109-2709a5557330.jpg?resize=1200%2C57 1200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/91a44cbe-753a-11ea-a109-2709a5557330.jpg 1700w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="Create a Notice"></a></div></section></div></div></div>
        </div><div id="modal-image-6b661881-3a60-552d-8ea3-d6e9001284af" class="modal fullscreen in modal-image image-mugshot modal-6b661881-3a60-552d-8ea3-d6e9001284af" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg"
                    srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg?resize=200%2C103 200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg?resize=250%2C129 300w"
                    sizes="100vw"
                    width="250"
                    height="129"
                    alt="ROOP,, Billy A."
                    class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-6b661881-3a60-552d-8ea3-d6e9001284af" data-target=".caption-inner-modal-image-6b661881-3a60-552d-8ea3-d6e9001284af">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-6b661881-3a60-552d-8ea3-d6e9001284af collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Fimage_6b661881-3a60-552d-8ea3-d6e9001284af.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/roop-billy-a/image_6b661881-3a60-552d-8ea3-d6e9001284af.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b661881-3a60-552d-8ea3-d6e9001284af"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=ROOP%2C%2C%20Billy%20A.&via=roanoketimes&url=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Fimage_6b661881-3a60-552d-8ea3-d6e9001284af.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/roop-billy-a/image_6b661881-3a60-552d-8ea3-d6e9001284af.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b661881-3a60-552d-8ea3-d6e9001284af"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://roanoke.com/obituaries/roop-billy-a/image_6b661881-3a60-552d-8ea3-d6e9001284af.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/roop-billy-a/image_6b661881-3a60-552d-8ea3-d6e9001284af.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b661881-3a60-552d-8ea3-d6e9001284af"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20roanoke.com/tncms/asset/editorial/6b661881-3a60-552d-8ea3-d6e9001284af" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"6b661881-3a60-552d-8ea3-d6e9001284af"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Broanoke.com%5D%20ROOP%2C%2C%20Billy%20A.&body=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Fimage_6b661881-3a60-552d-8ea3-d6e9001284af.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"6b661881-3a60-552d-8ea3-d6e9001284af"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/roop-billy-a/image_6b661881-3a60-552d-8ea3-d6e9001284af.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b661881-3a60-552d-8ea3-d6e9001284af"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-6b661881-3a60-552d-8ea3-d6e9001284af-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="6b661881-3a60-552d-8ea3-d6e9001284af" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="6b661881-3a60-552d-8ea3-d6e9001284af" class="save-list-6b661881-3a60-552d-8ea3-d6e9001284af-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="6b661881-3a60-552d-8ea3-d6e9001284af" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-6b661881-3a60-552d-8ea3-d6e9001284af img { max-height: 129px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-dd51a29f-a21e-588d-8f30-bce5fc65e419" class="asset article-default"  data-url="https://roanoke.com/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg?crop=229%2C129%2C10%2C0&resize=356%2C200&order=crop%2Cresize">
            <meta itemprop="width" content="356">
            <meta itemprop="height" content="200">
        </div>
        <meta itemprop="name" content="roanoke.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://roanoke.com/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html" />
    <div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            ROOP,, Billy A.
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2020-07-07T00:00:00-04:00" class="tnt-date asset-date text-muted">
            Jul 7, 2020
        </time>
    </li>
            <li class="hidden-print">
        <time datetime="2020-07-07T00:00:00-04:00" class="tnt-date asset-date text-muted">58 min ago</time></li>
        
        
            <li class="hidden-print"><a href="/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html#comments" class="cm" title="0 entries"><span class="fas tnt-book"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-07-07T00:00:00-04:00">
    <meta itemprop="datePublished" content="2020-07-07T00:00:00-04:00">
    <meta itemprop="dateModified" content="2020-07-07T00:00:00-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=ROOP%2C%2C%20Billy%20A.&via=roanoketimes&url=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://roanoke.com/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20roanoke.com/tncms/asset/editorial/dd51a29f-a21e-588d-8f30-bce5fc65e419" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Broanoke.com%5D%20ROOP%2C%2C%20Billy%20A.&body=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    
        <div class="asset-related-mugshot inline-asset inline-image hover-expand visible-xs" data-photo-target=".photo-6b661881-3a60-552d-8ea3-d6e9001284af" data-toggle="modal" data-instance="#gallery-items-dd51a29f-a21e-588d-8f30-bce5fc65e419-photo-modal" data-target="#photo-carousel-dd51a29f-a21e-588d-8f30-bce5fc65e419">
            <span class="expand"><span class="fas tnt-camera"></span>
            </span><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="250">
            <meta itemprop="height" content="129">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="ROOP,, Billy A."
                            class="img-responsive lazyload full default"
                            width="250"
                            height="129"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg?resize=200%2C103 200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg?resize=250%2C129 300w" />
            </div>
                
                
            </div>
            
                
                
            
        </figure></div>
    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="dd51a29f-a21e-588d-8f30-bce5fc65e419">
                

                <div class="row">
                    <div class="col-lg-8 col-md-12 col-sm-8 col-lg-push-4 col-md-push-0 col-sm-push-4" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=ROOP%2C%2C%20Billy%20A.&via=roanoketimes&url=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://roanoke.com/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20roanoke.com/tncms/asset/editorial/dd51a29f-a21e-588d-8f30-bce5fc65e419" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Broanoke.com%5D%20ROOP%2C%2C%20Billy%20A.&body=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-dd51a29f-a21e-588d-8f30-bce5fc65e419-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="dd51a29f-a21e-588d-8f30-bce5fc65e419" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="dd51a29f-a21e-588d-8f30-bce5fc65e419" class="save-list-dd51a29f-a21e-588d-8f30-bce5fc65e419-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="dd51a29f-a21e-588d-8f30-bce5fc65e419" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  p402_premium subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>ROOP, Billy A. April 20, 1949 - July 4, 2020 Billy A. Roop, of Christiansburg, passed away on Saturday, July 4, 2020, after a brief battle with liver cancer. He was 71 years old. Bill was born on April 20, 1949, in Tazewell, Va. He was employed by Radford Foundry and retired with 35 years of service. Bill was actively involved in the United Steel Workers Union Local 2969 and served through its ranks from Shop Steward to its President. Bill loved to gamble and enjoyed several trips to Atlantic City, New Jersey and West Virginia throughout his life. He loved the slots, Blackjack, and Poker. Bill was also a Mason. Bill met and married the love of his life, Betty Hutchison Roop, on May 31, 1969. Five years later they had a son, Chris. Bill was preceded in death by his father, James "Walter'" Roop and mother, Hershel Miller Roop; brothers, Teddy Roop and wife, Pat, Charlie Roop and wife, Brenda; mother and father-in-law, Thelma and Charles Hutchison; and brother-in-law, Danny Boling. Bill is survived by his loving wife of 51 years, Betty Hutchison Roop; son, Christopher Roop and fiancée, Kristal Fulcher; granddaughter, Macy Roop and fiancée, Logan Harris; siblings, Douglas "Eddie" Roop; Peggy Boling, Lakie Edwards (Jimmy), and Brenda "Pooge" Durham; several nieces and nephews, and other extended family; as well as his lifelong friend, Russell Shucker. In lieu of flowers, please make donations to Christiansburg Rescue Squad, Christiansburg Fire Department, or to your local Hospice organizations, who are truly angels on earth. Visitation will be held on Wednesday, July 8, 2020, from 11 a.m. until 1 p.m. at Horne Funeral Home The memorial service will begin at 1 p.m. in the Chapel, with the Rev. Sebert Rorrer.</p><div class="tnt-ads-container text-center hidden-sm hidden-md hidden-lg"><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad dfp-ad-lite" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="fixed-big-ad-top, atf, Right, 50" id="fixed-big-ad-top-mobile" data-dfp-size="[300,250]" data-subscriber="true"></div></div>
    <div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=ROOP%2C%2C%20Billy%20A.&via=roanoketimes&url=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://roanoke.com/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20roanoke.com/tncms/asset/editorial/dd51a29f-a21e-588d-8f30-bce5fc65e419" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Broanoke.com%5D%20ROOP%2C%2C%20Billy%20A.&body=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"dd51a29f-a21e-588d-8f30-bce5fc65e419"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-dd51a29f-a21e-588d-8f30-bce5fc65e419-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="dd51a29f-a21e-588d-8f30-bce5fc65e419" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="dd51a29f-a21e-588d-8f30-bce5fc65e419" class="save-list-dd51a29f-a21e-588d-8f30-bce5fc65e419-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="dd51a29f-a21e-588d-8f30-bce5fc65e419" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div><div class="col-lg-4 col-md-12 col-sm-4 col-md-pull-0 col-sm-pull-8 col-lg-pull-8" data-subscription-required-remove>
                            <aside class="related-sidebar default  p402_hide subscriber-hide">

                                

                                <div id="tncms-region-article_aside_top" class="tncms-region hidden-print"></div>

                                
                                

                                

                                

                                

                                
                                                <div class="asset-related-mugshot inline-asset inline-image hidden-xs">
                                                    <div class="hover-expand" data-toggle="modal"data-target=".modal-6b661881-3a60-552d-8ea3-d6e9001284af">
                                                        <span class="expand"><span class="fas tnt-camera"></span>
                                                        </span><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="250">
            <meta itemprop="height" content="129">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="ROOP,, Billy A."
                            class="img-responsive lazyload full default"
                            width="250"
                            height="129"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg?resize=200%2C103 200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/b6/6b661881-3a60-552d-8ea3-d6e9001284af/5f03e54360b59.image.jpg?resize=250%2C129 300w" />
            </div>
                
                
            </div>
            
                
                
            
        </figure></div></div>
                                            

                                

                                

                                

                                

                                

                                

                                <div id="tncms-region-article_aside_bottom" class="tncms-region hidden-print"></div>

                                

                                <div id="article-aside-sticky-spacer"><div id="tncms-region-article_aside_sticky" class="tncms-region hidden-print"></div></div>

                            </aside>
                        </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22bill%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-bill label label-default" data-tncms-track-dmp='search: bill'>Bill</a>
            </li> <li>
                <a href="/search/?k=%22work%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-work label label-default" data-tncms-track-dmp='search: work'>Work</a>
            </li> <li>
                <a href="/search/?k=%22unions%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-unions label label-default" data-tncms-track-dmp='search: unions'>Unions</a>
            </li> <li>
                <a href="/search/?k=%22christianity%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-christianity label label-default" data-tncms-track-dmp='search: christianity'>Christianity</a>
            </li> <li>
                <a href="/search/?k=%22thelma%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-thelma label label-default" data-tncms-track-dmp='search: thelma'>Thelma</a>
            </li> <li>
                <a href="/search/?k=%22brenda%20durham%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-brenda-durham label label-default" data-tncms-track-dmp='search: brenda-durham'>Brenda Durham</a>
            </li> <li>
                <a href="/search/?k=%22betty%20hutchison%20roop%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-betty-hutchison-roop label label-default" data-tncms-track-dmp='search: betty-hutchison-roop'>Betty Hutchison Roop</a>
            </li> <li>
                <a href="/search/?k=%22charles%20hutchison%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-charles-hutchison label label-default" data-tncms-track-dmp='search: charles-hutchison'>Charles Hutchison</a>
            </li> <li>
                <a href="/search/?k=%22billy%20a.%20roop%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-billy-a_-roop label label-default" data-tncms-track-dmp='search: billy-a_-roop'>Billy A. Roop</a>
            </li> <li>
                <a href="/search/?k=%22kristal%20fulcher%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-kristal-fulcher label label-default" data-tncms-track-dmp='search: kristal-fulcher'>Kristal Fulcher</a>
            </li> </ul>
                        </div>
                    

                    

                    
                        <div class="asset-tags hidden-print">
                           <h4>Locations</h4>
                             <ul class="list-inline"><li>
                <a href="/search/?g=new_river_valley" class="tag-new_river_valley label label-default" data-tncms-track-dmp='search: new_river_valley'>New River Valley</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    <div class="visible-lg visible-sm"><div class="tnt-ads-container text-center "><div style="min-height:250px; min-width:620px;" class="tnt-ads dfp-ad" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="article_links_1, btf, 50" id="article_links_1" data-dfp-size="[620,250]" data-lazy="true"></div></div>
    </div><div class="visible-md visible-xs"><div class="tnt-ads-container text-center "><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="article_links_1, btf, 50" id="article_links_1_sm" data-dfp-size="[300,250]" data-lazy="true"></div></div>
    </div>

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Add an entry<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="dd51a29f-a21e-588d-8f30-bce5fc65e419" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Adding">Add entry</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your entry has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch the guestbook.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this guestbook.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="dd51a29f-a21e-588d-8f30-bce5fc65e419" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone signs the guestbook.
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this guestbook will end.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container">
        <section id="comments" class=" p402_hide subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-book"></span> (0) entries 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom  usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Sign the guestbook.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://roanoke.com/users/login/?referer_url=https%3A%2F%2Froanoke.com%2Fobituaries%2Froop-billy-a%2Farticle_dd51a29f-a21e-588d-8f30-bce5fc65e419.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules">THANK YOU for helping us ensure that all guest book entries are
positive and considerate. If you see a negative or inappropriate
comment, please click on the link in the comment to report it, and
a staff member will follow up immediately.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Add an entry</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch the guestbook.</span>
                                    <span class="unsubscribe">Stop watching this guestbook.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div class="visible-lg visible-md visible-sm"><div class="tnt-ads-container text-center hidden-xs"><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad dfp-ad-lite" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="fixed-big-ad-top, atf, Right, 50" id="fixed-big-ad-top" data-dfp-size="[[300,250], [300,600]]" data-subscriber="true"></div></div>
    </div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"><div id="tncms-block-753567" class="tncms-block"><section id="block-753567" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-753567 ">
        <div class="block-title-inner">
            <h3>
                
                Most Popular
                
            </h3>
        </div>
    </div></div>
    <div class="card">
        <ul class="list-unstyled list-popular"><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/crime/roanoke-police-investigate-death-at-downtown-parking-garage/article_4fceab09-fafa-51d5-86f7-76b3c2171ca1.html" class="tnt-asset-link">
        

        
            Roanoke police investigate death at downtown parking garage</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/remembering-louis-tudor-one-of-a-kind/article_6fe38cb9-45a9-5b08-b095-d1c7074a1ef6.html" class="tnt-asset-link">
        

        
            Remembering Louis Tudor, 'one of a kind'</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/business/camp-closes-due-to-coronavirus-as-the-disease-infects-younger-people-in-the-roanoke-valley/article_5a762667-d7a8-5df5-a02f-0882f9e7e7f9.html" class="tnt-asset-link">
        

        
            Camp closes due to coronavirus as the disease infects younger people in the Roanoke Valley</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/local/as-the-state-prepares-for-broader-reopening-southwest-virginia-sees-rapid-covid-19-growth/article_978e4e44-5fad-56fa-81f8-b14d52fb9a71.html" class="tnt-asset-link">
        

        
            As the state prepares for broader reopening, Southwest Virginia sees rapid COVID-19 growth</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/education/allegation-of-republican-maneuvering-on-school-reopening-plan-highlights-roanoke-county-school-board-discord/article_2cf8a1cb-798c-524b-82a7-6441d9ba621b.html" class="tnt-asset-link">
        

        
            Allegation of Republican maneuvering on school reopening plan highlights Roanoke County School Board discord</a></h4>
                    
                </li></ul>
    </div>
    
</section></div></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-758749" class="tncms-block"><section id="block-758749" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-758749 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/obituaries">
                
                Obituary Sections
                
                    </a>
                
            </h4>
        </div>
    </div></div><div class="blox-autolist blox-autolist-758749 list-group"><a class="list-group-item" href="/obituaries/card_of_thanks/" title="Card Of Thanks">Card Of Thanks</a><a class="list-group-item" href="/obituaries/gallery/" title="Recent Obituaries Gallery">Recent Obituaries Gallery</a><a class="list-group-item" href="/obituaries/memoriams/" title="Memoriams">Memoriams</a><a class="list-group-item" href="/obituaries/search/" title="Obituary Search">Obituary Search</a></div></section></div><div id="tncms-block-753211" class="tncms-block"><section id="block-753211" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-753211 ">
        <div class="block-title-inner">
            <h4>
                
                In memory
                
            </h4>
        </div>
    </div></div><div class="card-bg-color ">
        
            
                <div class="card-panel panel">
                    <div class="panel-body">
            
            <article id="card-showcase-935812f1-5a22-51f4-aa92-024e3165e9fc" class="clearfix card showcase position-0 odd tnt-flag-spotlight tnt-flag-ap  tnt-section-news tnt-sub-section-national">
            <div class="card-container"><div class="card-image-group"><div class="showcase-box pull-left position-0 odd"><div class="media-preview-935812f1-5a22-51f4-aa92-024e3165e9fc media-preview collection-asset" data-aspect="1:1"><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/photos-notable-deaths-in-2020/collection_935812f1-5a22-51f4-aa92-024e3165e9fc.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Photos: Notable Deaths in 2020"
                            class="img-responsive lazyload ap-photo full default"
                            width="1080"
                            height="1080"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/9/35/935812f1-5a22-51f4-aa92-024e3165e9fc/5efcc865c6a2b.preview.jpg?crop=1080%2C1080%2C420%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/9/35/935812f1-5a22-51f4-aa92-024e3165e9fc/5efcc865c6a2b.preview.jpg?crop=1080%2C1080%2C420%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/9/35/935812f1-5a22-51f4-aa92-024e3165e9fc/5efcc865c6a2b.preview.jpg?crop=1080%2C1080%2C420%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/9/35/935812f1-5a22-51f4-aa92-024e3165e9fc/5efcc865c6a2b.preview.jpg?crop=1080%2C1080%2C420%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/9/35/935812f1-5a22-51f4-aa92-024e3165e9fc/5efcc865c6a2b.preview.jpg?crop=1080%2C1080%2C420%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/9/35/935812f1-5a22-51f4-aa92-024e3165e9fc/5efcc865c6a2b.preview.jpg?crop=1080%2C1080%2C420%2C0&resize=1080%2C1080&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></div></div><div class="showcase-box pull-left position-1 even"><div class="media-preview-5e04f73d-19ef-54d3-bd40-bd6625e45eb1 media-preview image-asset" data-aspect="1:1"><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/photos-notable-deaths-in-2020/collection_935812f1-5a22-51f4-aa92-024e3165e9fc.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Jerry Stiller"
                            class="img-responsive lazyload full default"
                            width="1240"
                            height="1240"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/5/e0/5e04f73d-19ef-54d3-bd40-bd6625e45eb1/5eeb586308b36.image.jpg?crop=1240%2C1240%2C215%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/5/e0/5e04f73d-19ef-54d3-bd40-bd6625e45eb1/5eeb586308b36.image.jpg?crop=1240%2C1240%2C215%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/5/e0/5e04f73d-19ef-54d3-bd40-bd6625e45eb1/5eeb586308b36.image.jpg?crop=1240%2C1240%2C215%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/5/e0/5e04f73d-19ef-54d3-bd40-bd6625e45eb1/5eeb586308b36.image.jpg?crop=1240%2C1240%2C215%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/5/e0/5e04f73d-19ef-54d3-bd40-bd6625e45eb1/5eeb586308b36.image.jpg?crop=1240%2C1240%2C215%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/5/e0/5e04f73d-19ef-54d3-bd40-bd6625e45eb1/5eeb586308b36.image.jpg?crop=1240%2C1240%2C215%2C0&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/5/e0/5e04f73d-19ef-54d3-bd40-bd6625e45eb1/5eeb586308b36.image.jpg?crop=1240%2C1240%2C215%2C0&resize=1240%2C1240&order=crop%2Cresize 1700w" />
                </a>
                
            </div>
            
        </figure></div></div><div class="showcase-box pull-left position-2 odd"><div class="media-preview-adf01956-a5d8-5aa2-8e84-62d9bd90d9fa media-preview image-asset" data-aspect="1:1"><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/photos-notable-deaths-in-2020/collection_935812f1-5a22-51f4-aa92-024e3165e9fc.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Don Shula"
                            class="img-responsive lazyload full default"
                            width="1166"
                            height="1166"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/a/df/adf01956-a5d8-5aa2-8e84-62d9bd90d9fa/5eeb58642b909.image.jpg?crop=1166%2C1166%2C305%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/a/df/adf01956-a5d8-5aa2-8e84-62d9bd90d9fa/5eeb58642b909.image.jpg?crop=1166%2C1166%2C305%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/a/df/adf01956-a5d8-5aa2-8e84-62d9bd90d9fa/5eeb58642b909.image.jpg?crop=1166%2C1166%2C305%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/a/df/adf01956-a5d8-5aa2-8e84-62d9bd90d9fa/5eeb58642b909.image.jpg?crop=1166%2C1166%2C305%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/a/df/adf01956-a5d8-5aa2-8e84-62d9bd90d9fa/5eeb58642b909.image.jpg?crop=1166%2C1166%2C305%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/a/df/adf01956-a5d8-5aa2-8e84-62d9bd90d9fa/5eeb58642b909.image.jpg?crop=1166%2C1166%2C305%2C0&resize=1166%2C1166&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></div></div><div class="showcase-box pull-left position-3 even"><div class="media-preview-3b6ac222-c03a-54c5-9736-c397404631a8 media-preview image-asset" data-aspect="1:1"><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/photos-notable-deaths-in-2020/collection_935812f1-5a22-51f4-aa92-024e3165e9fc.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Annie Glenn"
                            class="img-responsive lazyload full default"
                            width="1142"
                            height="1142"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/3/b6/3b6ac222-c03a-54c5-9736-c397404631a8/5eeb58655e94f.image.jpg?crop=1142%2C1142%2C335%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/3/b6/3b6ac222-c03a-54c5-9736-c397404631a8/5eeb58655e94f.image.jpg?crop=1142%2C1142%2C335%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/3/b6/3b6ac222-c03a-54c5-9736-c397404631a8/5eeb58655e94f.image.jpg?crop=1142%2C1142%2C335%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/3/b6/3b6ac222-c03a-54c5-9736-c397404631a8/5eeb58655e94f.image.jpg?crop=1142%2C1142%2C335%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/3/b6/3b6ac222-c03a-54c5-9736-c397404631a8/5eeb58655e94f.image.jpg?crop=1142%2C1142%2C335%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/3/b6/3b6ac222-c03a-54c5-9736-c397404631a8/5eeb58655e94f.image.jpg?crop=1142%2C1142%2C335%2C0&resize=1142%2C1142&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></div></div><div class="showcase-box pull-left position-4 odd"><div class="media-preview-74347db1-2dd8-5321-8d9d-46d2abb95576 media-preview image-asset" data-aspect="1:1"><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/photos-notable-deaths-in-2020/collection_935812f1-5a22-51f4-aa92-024e3165e9fc.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="John Prine"
                            class="img-responsive lazyload full default"
                            width="1176"
                            height="1176"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/7/43/74347db1-2dd8-5321-8d9d-46d2abb95576/5eeb5866c4e47.image.jpg?crop=1176%2C1176%2C293%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/7/43/74347db1-2dd8-5321-8d9d-46d2abb95576/5eeb5866c4e47.image.jpg?crop=1176%2C1176%2C293%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/7/43/74347db1-2dd8-5321-8d9d-46d2abb95576/5eeb5866c4e47.image.jpg?crop=1176%2C1176%2C293%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/7/43/74347db1-2dd8-5321-8d9d-46d2abb95576/5eeb5866c4e47.image.jpg?crop=1176%2C1176%2C293%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/7/43/74347db1-2dd8-5321-8d9d-46d2abb95576/5eeb5866c4e47.image.jpg?crop=1176%2C1176%2C293%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/7/43/74347db1-2dd8-5321-8d9d-46d2abb95576/5eeb5866c4e47.image.jpg?crop=1176%2C1176%2C293%2C0&resize=1176%2C1176&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></div></div><div class="clearfix"></div>
            </div><div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/national/photos-notable-deaths-in-2020/collection_935812f1-5a22-51f4-aa92-024e3165e9fc.html" class="tnt-asset-link">
        

        
            Photos: Notable Deaths in 2020</a></h4></div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
                    </div>
                </div>
            
        
    </div></section></div><div id="tncms-block-533464" class="tncms-block"><section id="block-533464" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-533464 ">
        <div class="block-title-inner">
            <h4>
                
                Submit An Obituary
                
            </h4>
        </div>
    </div></div><article class="card promo media"><div class="media-body"><p>Funeral homes often submit obituaries as a service to the families they are assisting. However, we will be happy to accept obituaries from family members pending proper verification of the death. If you wish to submit an obituary or in memoriam notice, you may contact us by calling 434-978-7294 or emailing obituary@roanoke.com or inmemory@roanoke.com</p></div>
</article></section></div></div><div class="visible-lg visible-md visible-sm"><div class="tnt-ads-container text-center hidden-xs"><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad dfp-ad-lite" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="fixed-big-ad-middle, stf, Right1" id="fixed-big-ad-middle" data-dfp-size="[[300,250], [300,600]]" data-lazy="true" data-subscriber="true"></div></div>
    </div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"><div id="tncms-block-753493" class="tncms-block"></div></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-749269" class="tncms-block visible-lg visible-md"><section id="block-749269" class="block emphasis-h4 dark  " ><div class="clearfix">
    
    <div class="block-title title-749269 ">
        <div class="block-title-inner">
            <h4>
                
                Obituaries in the news
                
            </h4>
        </div>
    </div></div>
    <div class=""><ul class="card headline-list bullet-square"><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/local/alonzo-big-al-hubbard-roanoke-baker-and-artist-dies-at-73/article_1d92a92b-228a-5165-9fb1-5e80b3cb68aa.html" class="tnt-asset-link">
        

        
            Alonzo 'Big Al' Hubbard, Roanoke baker and artist, dies at 73</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/obituaries/grabler-teresa-anne/article_bbb7642a-b209-5bea-b703-01d76e8e40f6.html" class="tnt-asset-link">
        

        
            Grabler, Teresa Anne</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/entertainment/music/remembering-neil-peart-drummer-for-rush-who-has-died-at-67/article_ba19f4f8-33ec-11ea-a7ba-eb8ef09c2bb2.html" class="tnt-asset-link">
        

        
            Remembering Neil Peart, drummer for Rush, who has died at 67</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/obituaries/hoel-barry-l/article_fc8f4893-4e85-5cb1-8a50-1b606482b12a.html" class="tnt-asset-link">
        

        
            Hoel, Barry L.</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/local/duke-curtis-former-president-of-hamlar-curtis-funeral-home-dies-at-63/article_80007546-757c-55d9-ae0b-be6bb928d8cb.html" class="tnt-asset-link">
        

        
            Duke Curtis, former president of Hamlar-Curtis Funeral Home, dies at 63</a></span>
        </li></ul></div></section></div><div id="tncms-block-749317" class="tncms-block"><section id="block-749317" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-749317 ">
        <div class="block-title-inner">
            <h4>
                
                Flowers
                
            </h4>
        </div>
    </div></div>

    <div id="business-grid-749317" class="business-cards card-grid  card-grid ">
        
        <div class="  ">
            
            
                
                    <div class="item ">
                        
                        <article id="card-summary-eb04b22b-2ab4-5b0a-95bf-879709dded46" class="clearfix card business enhanced  has-image" data-track-object='{"title":"Cahoon&#39;s Florist and Gifts | Fresh Flowers Delivered | Fincastle VA","url":"/findit/cahoon-s-florist-and-gifts-fresh-flowers-delivered-fincastle-va/business_4000050065.html","uuid":"eb04b22b-2ab4-5b0a-95bf-879709dded46","app":"business","metric":""}' data-tncms-tracking="business/block/eb04b22b-2ab4-5b0a-95bf-879709dded46">
            <div class="card-tag">
                    <div class="tag-bg"></div>
                    <div class="tag-txt" title="Enhanced Business" data-toggle="tooltip" data-placement="top">
                        <span class="fas tnt-star"></span>
                    </div>
                </div>
            
            <div class="card-container">
                
                <div class="card-image">
                    
                        <a href="/findit/cahoon-s-florist-and-gifts-fresh-flowers-delivered-fincastle-va/business_4000050065.html" >
                    <div class="media-preview-eb04b22b-2ab4-5b0a-95bf-879709dded46 media-preview business-asset" data-aspect="">
        <figure class="photo layout-square">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Cahoon's Florist and Gifts | Fresh Flowers Delivered | Fincastle VA"
                            class="img-responsive lazyload logo default"
                            width="300"
                            height="300"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/business/e/b0/eb04b22b-2ab4-5b0a-95bf-879709dded46/599c8268dbafa.preview-300.jpg?resize=200%2C200 200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/business/e/b0/eb04b22b-2ab4-5b0a-95bf-879709dded46/599c8268dbafa.preview-300.jpg?resize=300%2C300 300w" /></figure>
    
</div>
                        </a>
                    
                </div>
                
                <div class="card-body">
                    <div class="card-content">
                        <div class="card-headline">
                            
                            <h3 class="tnt-headline ">
        
             <a href="/findit/cahoon-s-florist-and-gifts-fresh-flowers-delivered-fincastle-va/business_4000050065.html" class="tnt-asset-link">
        

        
            Cahoon's Florist and Gifts | Fresh Flowers Delivered | Fincastle VA</a></h3>
                        </div>
                        <div class="card-contact "><div class="card-location">
                                    <a href="https://www.google.com/maps/dir//331%20Botetourt%20Rd%2BFincastle%2BVA%2B24090">
                                        331 Botetourt Rd, Fincastle, VA 24090
                                    </a>
                                </div>
                                <div class="card-phone">
                                    <i class="fas tnt-phone-square"></i>
                                    
                                    540-473-2601
                                    
                                </div>
                            </div><div class="card-classifieds-links">
            <ul class="list-inline hidden-print icon"><li>
                        <a rel="nofollow" title="Cahoon's Florist and Gifts | Fresh Flowers Delivered | Fincastle VA's website" href="http://www.cahoonsflorist.com/" target="_blank">
                            <i class="fas tnt-globe tnt-fw" aria-hidden="true"></i> <span class="hidden-xs">Website</span>
                        </a>
                    </li></ul>
        </div>
                    </div>
                </div>
            </div>
        </article>
                        
                    </div>
                    

                    

                
            
            
        </div>
    </div>

    

    </section>

    </div><div id="tncms-block-749316" class="tncms-block"><section id="block-749316" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-749316 ">
        <div class="block-title-inner">
            <h4>
                
                Sign A Guestbook
                
            </h4>
        </div>
    </div></div><article class="card promo media"><div class="media-body"><h3 class="media-heading">Offer a personal message of sympathy...</h3><p>You'll find individual Guest Books on the page with each obituary notice. By sharing a fond memory or writing a kind tribute, you will be providing a comforting keepsake to those in mourning. .
From a Guest Book, you may log in with your user account to leave a message. If you have an existing account with this site, you may log in with that. Otherwise, it's simple to create a new one by clicking on the Create "Sign up" button and following the simple steps on the Sign Up page.</p></div>
</article></section></div></div><div class="visible-lg visible-md visible-sm"><div class="tnt-ads-container text-center hidden-xs"><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="fixed-big-ad-bottom, btf, Right2, 70" id="fixed-big-ad-bottom" data-dfp-size="[[300,250], [300,600]]" data-lazy="true"></div></div>
    </div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-753587" class="tncms-block"><section id="block-753587" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-753587 ">
        <div class="block-title-inner">
            <h4>
                
                Contests &amp; Events
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-bg-color">
        
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-753587-6c47de18-b19e-11ea-b5f7-df064651e771" class="clearfix card summary has-image image-left inherit letterbox-style-default ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-6c47de18-b19e-11ea-b5f7-df064651e771 media-preview link-asset" data-aspect="original"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="https://www.roanoke.com/contests/hot-off-the-grill-sweepstakes/html_d15c5cc6-b198-11ea-a70e-e7ee887a8ed7.html#//" class="tnt-asset-link">
                
                
                
                
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Hot off the Grill Sweepstakes"
                    class="img-responsive lazyload  letterbox default"
                    width="733"
                    height="750"
                    data-src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/6/c4/6c47de18-b19e-11ea-b5f7-df064651e771/5eebc866a81a2.preview.jpg?resize=200%2C205" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="https://www.roanoke.com/contests/hot-off-the-grill-sweepstakes/html_d15c5cc6-b198-11ea-a70e-e7ee887a8ed7.html#//" class="tnt-asset-link">
        

        
            Hot off the Grill Sweepstakes</a></h4></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">This month we're giving you the chance to win a $100 VISA GIFT CARD to go towards your next &hellip;</p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-753587-d2948794-a68f-11ea-af20-6b1a36ad237c" class="clearfix card summary has-image image-left inherit letterbox-style-default ">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-d2948794-a68f-11ea-af20-6b1a36ad237c media-preview link-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="https://www.roanoke.com/contests/dad-and-me-look-a-like-photo-contest/html_326a45e2-a1d0-11ea-b69c-0f900d587ec3.html#/gallery" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Dad and Me Look-A-Like Photo Contest"
                            class="img-responsive lazyload full default"
                            width="234"
                            height="132"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/d/29/d2948794-a68f-11ea-af20-6b1a36ad237c/5ed93b8c20b37.preview.png?resize=200%2C113 200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/assets/v3/editorial/d/29/d2948794-a68f-11ea-af20-6b1a36ad237c/5ed93b8c20b37.preview.png?resize=234%2C132 300w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="https://www.roanoke.com/contests/dad-and-me-look-a-like-photo-contest/html_326a45e2-a1d0-11ea-b69c-0f900d587ec3.html#/gallery" class="tnt-asset-link">
        

        
            Dad and Me Look-A-Like Photo Contest</a></h4></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">Do you and your Dad look a-like? Do you know someone that looks like theirs? PERFECT! We’d l&hellip;</p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            </div></section></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"><div id="tncms-block-748895" class="tncms-block"><div class="tnt-ads-container text-center "><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="fixed-big-ad-bottom, Right2" id="ad-748895" data-dfp-size="[[300,250], [300,600]]" data-lazy="true"></div></div>
    
</div></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div><div class="container-breakout"><div class="visible-lg visible-md"><div class="tnt-ads-container text-center hidden-xs"><div style="min-height:90px; min-width:728px;" class="tnt-ads dfp-ad" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="fixed-leaderboard-bottom, btf, Bottom, Position3" id="fixed-leaderboard-bottom" data-dfp-size="[[728,90], [970,90], [970,250]]" data-lazy="true"></div></div>
    </div><div class="visible-sm"><div class="tnt-ads-container text-center hidden-xs"><div style="min-height:90px; min-width:728px;" class="tnt-ads dfp-ad" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="fixed-leaderboard-bottom, btf, Bottom, Position3" id="fixed-leaderboard-bottom-tablet" data-dfp-size="[728,90]" data-lazy="true"></div></div>
    </div><div class="tnt-ads-container text-center hidden-sm hidden-md hidden-lg"><div style="min-height:50px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/167885573/roanoke/obituaries" data-dfp-custom-pos="fixed-leaderboard-bottom, btf, Bottom, Position3" id="fixed-leaderboard-bottom-mobile" data-dfp-size="[[300,50], [320,50]]" data-lazy="true"></div></div>
    </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-756914" class="tncms-block"><div id="site-logo-756914" class="site-logo-container text-left" >
        <div class="logo-top"></div>
        <div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/52a74a82-473e-11e9-be84-6b5adc4da9f4.png?resize=200%2C22" 
            srcset="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/52a74a82-473e-11e9-be84-6b5adc4da9f4.png?resize=200%2C22 200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/52a74a82-473e-11e9-be84-6b5adc4da9f4.png?resize=300%2C33 300w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/52a74a82-473e-11e9-be84-6b5adc4da9f4.png?resize=400%2C44 400w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/52a74a82-473e-11e9-be84-6b5adc4da9f4.png?resize=540%2C59 540w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/52a74a82-473e-11e9-be84-6b5adc4da9f4.png?resize=750%2C82 750w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/52a74a82-473e-11e9-be84-6b5adc4da9f4.png?resize=1200%2C131 1200w, https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/custom/image/52a74a82-473e-11e9-be84-6b5adc4da9f4.png?resize=1700%2C185 1700w"
            sizes="100vw"
            class=" img-responsive lazyload tnt-prop-img"
            alt="site-logo"></a>
        </div>
        <div class="logo-bottom"></div>
    </div></div><div id="tncms-block-756915" class="tncms-block padding-bottom"><div class="follow-links-756915 default">
    
    <section id="block-756915" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/roanoketimes/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.twitter.com/roanoketimes" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
            <li>
                <a href="https://instagram.com/roanoketimes/" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
            <li>
                <a href="/emails/" title="Email" target="_blank" rel="noopener" class="btn btn-xs btn-link em" data-toggle="tooltip" data-placement="bottom">
                    <i class="fas tnt-envelope"></i>
                    <span class="sr-only">Email</span>
                </a>
            </li>
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://roanoke.com",
  "sameAs" : ["https://www.facebook.com/roanoketimes/","https://www.twitter.com/roanoketimes","https://instagram.com/roanoketimes/","/emails/"]
}
</script>
<div class="clearfix"></div></div></div>
        
        <div id="tncms-region-footer-col-one-under" class="tncms-region "></div>
    </div>
    <div id="footer-col-two" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-749070" class="tncms-block site-footer-heading"><section id="block-749070" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-749070 ">
        <div class="block-title-inner">
            <h4>
                
                Products &amp; Features
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-place-an-ad"  href="https://ads.roanoke.com/roanoke-adportal/classified/index.html"  target="_blank" rel="noopener">
                    <span class="nav-label">Place an Ad</span>
                </a></li><li>
                <a class="nav-link  tnt-section-newsletters"  href="https://www.roanoke.com/emails/"  target="_blank" rel="noopener">
                    <span class="nav-label">Newsletters</span>
                </a></li><li>
                <a class="nav-link  tnt-section-todays-deal"  href="https://roanoke.scoreyourdeal.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Today's Deal</span>
                </a></li><li>
                <a class="nav-link  tnt-section-join-our-team"  href="https://us851.dayforcehcm.com/CandidatePortal/en-US/bhmedia/"  target="_blank" rel="noopener">
                    <span class="nav-label">Join our Team</span>
                </a></li><li>
                <a class="nav-link  tnt-section-public-notices"  href="/classifieds/community/announcements/legal" >
                    <span class="nav-label">Public Notices</span>
                </a></li></ul></div>
        <div id="tncms-region-footer-col-two-under" class="tncms-region "></div>
    </div>
    <div id="footer-col-three" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-749063" class="tncms-block site-footer-heading"><section id="block-749063" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-749063 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-manage-subscription"  href="https://myaccount.roanoke.com/Dashboard"  target="_blank" rel="noopener">
                    <span class="nav-label">Manage Subscription</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertise"  href="/site/contact.html" >
                    <span class="nav-label">Advertise</span>
                </a></li><li>
                <a class="nav-link  tnt-section-photo-submissions"  href="/photosubmissions/" >
                    <span class="nav-label">Photo Submissions</span>
                </a></li><li>
                <a class="nav-link  tnt-section-website-problems"  href="/site/forms/online_services/submit_website_problem/" >
                    <span class="nav-label">Website Problems</span>
                </a></li><li>
                <a class="nav-link  tnt-section-professional-standards-and-content-policies"  href="/site/professional_standards.html" >
                    <span class="nav-label">Professional Standards and Content Policies</span>
                </a></li><li>
                <a class="nav-link  tnt-section-carrier-services"  href="https://subscribe3.gatewayva.com/authenticate.htm?p_publication=3400"  target="_blank" rel="noopener">
                    <span class="nav-label">Carrier Services</span>
                </a></li></ul></div>
        <div id="tncms-region-footer-col-three-under" class="tncms-region "></div>
    </div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
    <!-- code here -->

            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-749075" class="tncms-block">
<style type="text/css">
    div.bh-custom-footer {display: table; width: 100%; margin: 10px 0;}
    div.bh-custom-footer > span {color: #000 !important; font-size: 9pt !important; font-family: 'Open Sans', sans-serif !important;}
    div.bh-custom-footer > span > a {color: #000 !important;}
</style>
<div class="bh-custom-footer">
    <span>
    Roanoke Times, Roanoke, VA &copy;2020 Lee BHM Corp.
     | <a href="/site/terms.html">Terms of Use</a>
     | <a href="/site/terms.html/#privacy">Privacy Policy</a>
     | This website is intended for U.S. residents only.
    </span>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    <div id="notification-panel" class="notify-panel notify-panel-from-right">
            <template>
                <div class="notification-item">
                    <a href="{{url}}" target="_blank"></a>
                    <div class="notification-item-card">
                        <div class="notification-item-image"><img src="{{image}}"></div>
                        <div class="notification-item-content">
                            <div class="notification-item-header">{{title}}</div>
                            <div class="notification-item-summary">{{summary}}</div>
                        </div>
                    </div>
                    <div class="notification-item-dismiss">
                        <i class="fas tnt-times tnt-fw"></i>
                    </div>
                </div>
            </template>
            <div class="notify-panel-container">
                <div class="notify-panel-header">
                    <div class="notify-panel-close"><i class="fas tnt-times tnt-fw"></i></div>
                    <div class="notify-panel-nav" role="tablist">
                        <ul>
                            <li class="active" role="presentation"><a href="#notify-panel-content" role="tab" data-toggle="tab">Notifications</a></li>
                            <li role="presentation"><a href="#notify-panel-settings" role="tab" data-toggle="tab">Settings</a></li>
                        </ul>
                    </div>
                </div>
                <div class="tab-content">
                    <div id="notify-panel-content" class="tab-pane active" role="tabpanel">
                        <div class="notify-panel-content-items"></div>
                        <div class="notify-panel-content-no-items" style="display:none;">You don't have any notifications.</div>
                    </div>
                    <div id="notify-panel-settings" class="tab-pane" role="tabpanel">
                        <div class="notify-panel-settings-promo">
                            <p>Get up-to-the-minute news sent straight to your device.</p>
                        </div>
                        
                        <h5>Topics</h5>
                        
                            <div class="topic-container" data-name="breaking">
                                <h4>Breaking News</h4>
                                <label class="switch-label">
                                    <span class="sr-only">Subscribe</span>
                                    <input id="topic-breaking" class="switch-input" title="topic-breaking" name="topic-breaking" data-topic="breaking" type="checkbox">
                                    <div class="switch-track"></div>
                                    <div class="switch-thumb"></div>
                                </label>
                            </div>
                        
                            <div class="topic-container" data-name="breaking_sports">
                                <h4>Sports Breaking News</h4>
                                <label class="switch-label">
                                    <span class="sr-only">Subscribe</span>
                                    <input id="topic-breaking_sports" class="switch-input" title="topic-breaking_sports" name="topic-breaking_sports" data-topic="breaking_sports" type="checkbox">
                                    <div class="switch-track"></div>
                                    <div class="switch-thumb"></div>
                                </label>
                            </div>
                        
                        
                        <div class="notify-panel-settings-error alert alert-danger" style="display:none; opacity:0;"></div>
                        <div class="notify-panel-settings-success alert alert-success" style="display:none; opacity:0;"></div>
                    </div>
                </div>
            </div>
        </div>
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("dd51a29f-a21e-588d-8f30-bce5fc65e419")});});
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                	_cc6892.add('act', dmpData);
	_cc6892.bcp();

            });
        });
    </script>
    
    <!-- Per BMT-6423 by RMD -->
    

        <script type="text/javascript">
        
        PARSELY = {
           
            // after PARSELY tracking code loads asynchronously
            onload: function() {
                console.info('PARSELY.onLoad() fired ');
            
                
                    // giving us a chance to do stuff then trigger
                    // the original TN Core event
                    __tnt._trackEvent = __tnt.trackEvent;
                    __tnt.trackEvent = function (obj) {
                        var isAdminVenue = false;
                        if (typeof obj == 'object' && !isAdminVenue) {
                            var url = 'http://roanoke.com' + obj.url;
                            var urlref = 'https://roanoke.com/obituaries/roop-billy-a/article_dd51a29f-a21e-588d-8f30-bce5fc65e419.html';
                            
                            PARSELY.beacon.trackPageView({
                                url: (url != '' ? url : this.href),
                                urlref: (urlref != '' ? urlref : location.href),
                                js: 1,
                                
                            });
                        }
                        // Trigger TN's Core method
                        __tnt._trackEvent(obj);
                    }
                    return true;
                }
            };
    </script>
    
    <!-- START Parse.ly Include: Standard -->
    <div id="parsely-root" style="display: none">
      <span id="parsely-cfg" data-parsely-site="roanoke.com"></span>
    </div>
    <script>
        (function(s, p, d) {
          var h=d.location.protocol, i=p+"-"+s,
              e=d.getElementById(i), r=d.getElementById(p+"-root"),
              u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
              :"static."+p+".com";
          if (e) return;
          e = d.createElement(s); e.id = i; e.async = true;
          e.src = h+"//"+u+"/p.js"; r.appendChild(e);
        })("script", "parsely", document);
    </script>
    <!-- END Parse.ly Include: Standard -->


<script src="https://tagan.adlightning.com/bhmedia/blacklist_script.js"></script>
<script src="https://tagan.adlightning.com/bhmedia/blocking_script.js"></script>
<script src="https://tagan.adlightning.com/bhmedia/op.js"></script>
<script>/*<![CDATA[*/ function articleShareSticky(){
                setTimeout(function(){
                    var sMainTop = document.querySelector('#main-body-container').offsetTop,
                        oNavBar = document.querySelector('#site-navbar-container');
                    if (sMainTop < window.scrollY){
                        oNavBar.classList.add('article-share')
                    } else {
                        oNavBar.classList.remove('article-share')
                    }
                }, 150)
            }
            document.addEventListener('scroll', articleShareSticky); /*]]>*/</script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script>/*<![CDATA[*/ var tnt_adTimerNum = 30000;
        var tnt_adTimerCalled = 0;
        var tnt_adTimer = setTimeout(tnt_adTimerEvent, tnt_adTimerNum);
        function tnt_adTimerEvent(){
            if( tnt_adTimerCalled === 3 ) {
                clearInterval(tnt_adTimerCalled);
            } else {
                try {
            
            var bOnlyDFP = false, bIsOAS = false;
            if( typeof __tnt.ads.dfp != 'undefined' ){
                    bOnlyDFP = true;
                googletag.cmd.push(function(){
                        googletag.pubads().clear([__tnt.ads.dfp.slots['fixed-big-ad-top'].dfp_slot,__tnt.ads.dfp.slots['fixed-big-ad-middle'].dfp_slot]);
                        googletag.pubads().refresh([__tnt.ads.dfp.slots['fixed-big-ad-top'].dfp_slot,__tnt.ads.dfp.slots['fixed-big-ad-middle'].dfp_slot]);
                    });
                }
                /* reloadByIds will return false/0 if the ad slot called for hasn't actually been loaded to the page. */
                if( typeof __tnt.ads.oas != 'undefined' ) bIsOAS = !!__tnt.ads.oas.reloadByIds(['fixed-big-ad-top','fixed-big-ad-middle']);
            
                if( !bOnlyDFP && !bIsOAS && typeof TNCMS.AdManager != 'undefined' ){
                        TNCMS.AdManager.refresh({region: 'fixed-big-ad-top'});
                        TNCMS.AdManager.refresh({region: 'fixed-big-ad-middle'});}
            } catch(e) {
            __tnt.log(e);
        }
                tnt_adTimer = setTimeout(tnt_adTimerEvent, tnt_adTimerNum);
            }
            tnt_adTimerCalled++;
        } /*]]>*/</script>
<script>/*<![CDATA[*/ window.addEventListener('DOMContentLoaded', function() {
                (function (callback) { var oScript; var oStorage; try { oStorage = JSON.parse(sessionStorage.getItem('tncms.dmp.audiences')); if (!oStorage || !oStorage.audiences || !oStorage.expired) { throw "Not in session storage"; } if (oStorage.expired < new Date().getTime()) { sessionStorage.removeItem('tncms.dmp.audiences'); throw "Cache is expired"; } callback(oStorage.audiences); } catch(oException) { if (!window.tncms_siteaud) { window.tncms_siteaud = null; } oScript = document.createElement('script'); oScript.onerror = function() { callback([]); }; oScript.onload = function() { try { var oResult = { audiences:[], expired: new Date().getTime() + 86400000 }; if (!window.tncms_siteaud) { return; } for(var nIdx = 0; nIdx < window.tncms_siteaud.Profile.Audiences.Audience.length; nIdx++) { var sAbbr = window.tncms_siteaud.Profile.Audiences.Audience[nIdx].abbr; oResult.audiences[oResult.audiences.length] = sAbbr; } oResult.audiences.sort(); sessionStorage.setItem('tncms.dmp.audiences', JSON.stringify(oResult)); } catch(oException) { if (console && console.warn) { console.warn('Failed to add behaviors to session storage'); } } callback(oResult.audiences); }; oScript.setAttribute('async', true); oScript.setAttribute('src', '//ad.crwdcntrl.net/5/c=6878/pe=y/var=tncms_siteaud'); var aHead = document.getElementsByTagName("head"); if (aHead && aHead[0]) { if (TNCMS && TNCMS.Tracking) { var oTracker = TNCMS.Tracking.createBucket({ 'app': 'tncms-dmp', 'metric': 'audience-extraction', 'data': { name: 'client', value: 6878 } }); oTracker.addEvent(new Date().getTime()); } aHead[0].appendChild(oScript); } } })(__tnt.dmp.audienceExtracted);
            }); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/dmp.reactive.0e53d3f9d235eed93a6018d451147284.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sticky-kit.1509acefe2ad7aac108313ac4c477d63.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.54d9f15b0d238de6bb20ec82ed8307ac.js"></script>
<script>/*<![CDATA[*/ (function() {
                    window.addEventListener('load', function() {
                        __tnt.regions.stickySide.init(document.getElementById('sticky-right-rail'), document.getElementById('sticky-right-rail-spacer'), 'siderail', '.row');
                    });
                })(); /*]]>*/</script>
<script>/*<![CDATA[*/ function messagingCallback(oPayload) {
                __tnt.notify({
                    title: oPayload.title,
                    message: oPayload.body,
                    url: oPayload.url,
                    image: oPayload.icon,
                    duration: 6000,
                    utm: {
                        'utm_source':'BLOX Broadcast',
                        'utm_campaign':'Push Notification',
                        'utm_medium':'referral',
                        'utm_content':'in-page notification'
                    }
                }).showNotification();
            } /*]]>*/</script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = Cookies.get('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            	_cc6892.add('act', serviceData);
	_cc6892.bcp();

                        }
                    }
                    Cookies.set('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        	_cc6892.add('act', dmpData);
	_cc6892.bcp();

                    }
                }
            }
         /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/roanoke.com/content/tncms/live/libraries/flex/components/ads_dfp/resources/scripts/dfp.lazy.min.js?_dc=1584380199"></script></body>
</html>